re = /(\d)[\s.]+(?=\d)/m
str = 'This is an 8-string 12.34.5678; and this is another 13-string 1234 5678 9123 0 okay?'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result