const regex = /(\d)[\s.]+(?=\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d)[\\s.]+(?=\\d)', 'gm')
const str = `This is an 8-string 12.34.5678; and this is another 13-string 1234 5678 9123 0 okay?`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);