use strict;
my $str = 'This is an 8-string 12.34.5678; and this is another 13-string 1234 5678 9123 0 okay?';
my $regex = qr/(\d)[\s.]+(?=\d)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";