#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d)[\s.]+(?=\d)"
Local $sString = "This is an 8-string 12.34.5678; and this is another 13-string 1234 5678 9123 0 okay?"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)