import Foundation
let pattern = #"(\d)[\s.]+(?=\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"This is an 8-string 12.34.5678; and this is another 13-string 1234 5678 9123 0 okay?"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)