#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([A-Z][A-Z]\d{4})\b(?:(?![A-Z][A-Z]\d{4}).)*\bgold\b"
Local $sString = "HX3923, width: 0.3, height: 0.7, gold, HX3924, color="blue", width=0.3" & @CRLF & _
"" & @CRLF & _
"HX3923, width: 0.3, height: 0.7, gold, HX3924, color="blue", width=0.3 HX3923, width: 0.3, height: 0.7, gold HX3923, width: 0.3, height: 0.7, gold HX3924, color="blue", width=0.3 HX3924, color="blue", width=0.3 HX3923, width: 0.3, height: 0.7, gold"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")