const regex = /\b([A-Z][A-Z]\d{4})\b(?:(?![A-Z][A-Z]\d{4}).)*\bgold\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([A-Z][A-Z]\\d{4})\\b(?:(?![A-Z][A-Z]\\d{4}).)*\\bgold\\b', 'gm')
const str = `HX3923, width: 0.3, height: 0.7, gold, HX3924, color="blue", width=0.3
HX3923, width: 0.3, height: 0.7, gold, HX3924, color="blue", width=0.3 HX3923, width: 0.3, height: 0.7, gold HX3923, width: 0.3, height: 0.7, gold HX3924, color="blue", width=0.3 HX3924, color="blue", width=0.3 HX3923, width: 0.3, height: 0.7, gold`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}