import re
regex = re.compile(r"\b([A-Z][A-Z]\d{4})\b(?:(?![A-Z][A-Z]\d{4}).)*\bgold\b", flags=re.MULTILINE)
test_str = ("HX3923, width: 0.3, height: 0.7, gold, HX3924, color=\"blue\", width=0.3\n\n"
"HX3923, width: 0.3, height: 0.7, gold, HX3924, color=\"blue\", width=0.3 HX3923, width: 0.3, height: 0.7, gold HX3923, width: 0.3, height: 0.7, gold HX3924, color=\"blue\", width=0.3 HX3924, color=\"blue\", width=0.3 HX3923, width: 0.3, height: 0.7, gold")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")