$re = '/\b([A-Z][A-Z]\d{4})\b(?:(?![A-Z][A-Z]\d{4}).)*\bgold\b/m';
$str = 'HX3923, width: 0.3, height: 0.7, gold, HX3924, color="blue", width=0.3
HX3923, width: 0.3, height: 0.7, gold, HX3924, color="blue", width=0.3 HX3923, width: 0.3, height: 0.7, gold HX3923, width: 0.3, height: 0.7, gold HX3924, color="blue", width=0.3 HX3924, color="blue", width=0.3 HX3923, width: 0.3, height: 0.7, gold';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);