import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([A-Z][A-Z]\\d{4})\\b(?:(?![A-Z][A-Z]\\d{4}).)*\\bgold\\b";
final String string = "HX3923, width: 0.3, height: 0.7, gold, HX3924, color=\"blue\", width=0.3\n\n"
+ "HX3923, width: 0.3, height: 0.7, gold, HX3924, color=\"blue\", width=0.3 HX3923, width: 0.3, height: 0.7, gold HX3923, width: 0.3, height: 0.7, gold HX3924, color=\"blue\", width=0.3 HX3924, color=\"blue\", width=0.3 HX3923, width: 0.3, height: 0.7, gold";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}