use strict;
my $str = 'HX3923, width: 0.3, height: 0.7, gold, HX3924, color="blue", width=0.3
HX3923, width: 0.3, height: 0.7, gold, HX3924, color="blue", width=0.3 HX3923, width: 0.3, height: 0.7, gold HX3923, width: 0.3, height: 0.7, gold HX3924, color="blue", width=0.3 HX3924, color="blue", width=0.3 HX3923, width: 0.3, height: 0.7, gold';
my $regex = qr/\b([A-Z][A-Z]\d{4})\b(?:(?![A-Z][A-Z]\d{4}).)*\bgold\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}