using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^123\.45\.116\.([0-9]|[0-1][0-9]|2[0-4])$";
string input = @"123.45.116.0
123.45.116.1
123.45.116.25
123.45.116.24
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}