re = /^123\.45\.116\.([0-9]|[0-1][0-9]|2[0-4])$/m
str = '123.45.116.0
123.45.116.1
123.45.116.25
123.45.116.24
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end