const regex = /^123\.45\.116\.([0-9]|[0-1][0-9]|2[0-4])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^123\\.45\\.116\\.([0-9]|[0-1][0-9]|2[0-4])$', 'gm')
const str = `123.45.116.0
123.45.116.1
123.45.116.25
123.45.116.24
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}