import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^123\\.45\\.116\\.([0-9]|[0-1][0-9]|2[0-4])$";
final String string = "123.45.116.0\n"
+ "123.45.116.1\n"
+ "123.45.116.25\n"
+ "123.45.116.24\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}