$re = '/^123\.45\.116\.([0-9]|[0-1][0-9]|2[0-4])$/m';
$str = '123.45.116.0
123.45.116.1
123.45.116.25
123.45.116.24
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);