package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^123\.45\.116\.([0-9]|[0-1][0-9]|2[0-4])$`)
var str = `123.45.116.0
123.45.116.1
123.45.116.25
123.45.116.24
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}