#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(§\s)([0-9:.]*)\.(\w+.*$)"
Local $sString = "§ 34:149.Lorem ipsum dolor sit amet" & @CRLF & _
"§ 53:178.40.Lorem ipsum dolor sit amet" & @CRLF & _
"§ 53:178.40.50.60.Lorem ipsum dolor sit amet" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")