// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(§\s)([0-9:.]*)\.(\w+.*$)").unwrap();
let string = "§ 34:149.Lorem ipsum dolor sit amet
§ 53:178.40.Lorem ipsum dolor sit amet
§ 53:178.40.50.60.Lorem ipsum dolor sit amet
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}