import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(§\\s)([0-9:.]*)\\.(\\w+.*$)";
final String string = "§ 34:149.Lorem ipsum dolor sit amet\n"
+ "§ 53:178.40.Lorem ipsum dolor sit amet\n"
+ "§ 53:178.40.50.60.Lorem ipsum dolor sit amet\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}