using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(§\s)([0-9:.]*)\.(\w+.*$)";
string input = @"§ 34:149.Lorem ipsum dolor sit amet
§ 53:178.40.Lorem ipsum dolor sit amet
§ 53:178.40.50.60.Lorem ipsum dolor sit amet
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}