$re = '/^(§\s)([0-9:.]*)\.(\w+.*$)/m';
$str = '§ 34:149.Lorem ipsum dolor sit amet
§ 53:178.40.Lorem ipsum dolor sit amet
§ 53:178.40.50.60.Lorem ipsum dolor sit amet
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);