package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(§\s)([0-9:.]*)\.(\w+.*$)`)
var str = `§ 34:149.Lorem ipsum dolor sit amet
§ 53:178.40.Lorem ipsum dolor sit amet
§ 53:178.40.50.60.Lorem ipsum dolor sit amet
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}