#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(,\s*"(queueNumber|name|uniqueNumber)\d*":\s*(".*?"|\d+.\d+|\w+))|("(queueNumber|name|uniqueNumber)\d*":\s*(".*?"|\d+.\d+|\w+)(\s*,)?)"
Local $sString = "{"queueNumber": "123"}" & @CRLF & _
"{"queueNumber": "123","UserId":[12,12,34],"cur":[{"objectName":"test","uniqueNumber":"123456"}]}" & @CRLF & _
"" & @CRLF & _
"{"field":"value","queueNumber": "123","UserId":[12,12,34],"cur":[{"objectName":"test","uniqueNumber":"123456"}]}" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)