using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(,\s*""(queueNumber|name|uniqueNumber)\d*"":\s*("".*?""|\d+.\d+|\w+))|(""(queueNumber|name|uniqueNumber)\d*"":\s*("".*?""|\d+.\d+|\w+)(\s*,)?)";
string substitution = @"";
string input = @"{""queueNumber"": ""123""}
{""queueNumber"": ""123"",""UserId"":[12,12,34],""cur"":[{""objectName"":""test"",""uniqueNumber"":""123456""}]}
{""field"":""value"",""queueNumber"": ""123"",""UserId"":[12,12,34],""cur"":[{""objectName"":""test"",""uniqueNumber"":""123456""}]}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}