re = /(,\s*"(queueNumber|name|uniqueNumber)\d*":\s*(".*?"|\d+.\d+|\w+))|("(queueNumber|name|uniqueNumber)\d*":\s*(".*?"|\d+.\d+|\w+)(\s*,)?)/m
str = '{"queueNumber": "123"}
{"queueNumber": "123","UserId":[12,12,34],"cur":[{"objectName":"test","uniqueNumber":"123456"}]}
{"field":"value","queueNumber": "123","UserId":[12,12,34],"cur":[{"objectName":"test","uniqueNumber":"123456"}]}
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result