use strict;
my $str = '{"queueNumber": "123"}
{"queueNumber": "123","UserId":[12,12,34],"cur":[{"objectName":"test","uniqueNumber":"123456"}]}
{"field":"value","queueNumber": "123","UserId":[12,12,34],"cur":[{"objectName":"test","uniqueNumber":"123456"}]}
';
my $regex = qr/(,\s*"(queueNumber|name|uniqueNumber)\d*":\s*(".*?"|\d+.\d+|\w+))|("(queueNumber|name|uniqueNumber)\d*":\s*(".*?"|\d+.\d+|\w+)(\s*,)?)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";