package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(,\s*"(queueNumber|name|uniqueNumber)\d*":\s*(".*?"|\d+.\d+|\w+))|("(queueNumber|name|uniqueNumber)\d*":\s*(".*?"|\d+.\d+|\w+)(\s*,)?)`)
var str = `{"queueNumber": "123"}
{"queueNumber": "123","UserId":[12,12,34],"cur":[{"objectName":"test","uniqueNumber":"123456"}]}
{"field":"value","queueNumber": "123","UserId":[12,12,34],"cur":[{"objectName":"test","uniqueNumber":"123456"}]}
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}