import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(,\\s*\"(queueNumber|name|uniqueNumber)\\d*\":\\s*(\".*?\"|\\d+.\\d+|\\w+))|(\"(queueNumber|name|uniqueNumber)\\d*\":\\s*(\".*?\"|\\d+.\\d+|\\w+)(\\s*,)?)";
final String string = "{\"queueNumber\": \"123\"}\n"
+ "{\"queueNumber\": \"123\",\"UserId\":[12,12,34],\"cur\":[{\"objectName\":\"test\",\"uniqueNumber\":\"123456\"}]}\n\n"
+ "{\"field\":\"value\",\"queueNumber\": \"123\",\"UserId\":[12,12,34],\"cur\":[{\"objectName\":\"test\",\"uniqueNumber\":\"123456\"}]}\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}