# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<img [^>]*)(srcset="[^"]*")([^>]*>)/<picture>\n<source \2 type="image\/webp">\n\1\3\n<\/picture>\n/gm;t' <<< "<img src=\"/media/blog/JPG/3.jpg\" srcset=\"/media/blog/3.webp\" alt=\"гардеробная\"><img src=\"/media/blog/JPG/4.jpg\" srcset=\"/media/blog/4.webp\" alt=\"гардеробная\">
"