import Foundation
let pattern = #"(<img [^>]*)(srcset="[^"]*")([^>]*>)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<img src="/media/blog/JPG/3.jpg" srcset="/media/blog/3.webp" alt="гардеробная"><img src="/media/blog/JPG/4.jpg" srcset="/media/blog/4.webp" alt="гардеробная">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<picture>\n<source \2 type="image/webp">\n\1\3\n</picture>\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)