re = /(<img [^>]*)(srcset="[^"]*")([^>]*>)/m
str = '<img src="/media/blog/JPG/3.jpg" srcset="/media/blog/3.webp" alt="гардеробная"><img src="/media/blog/JPG/4.jpg" srcset="/media/blog/4.webp" alt="гардеробная">
'
subst = '<picture>\\n<source \\2 type="image/webp">\\n\\1\\3\\n</picture>\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result