using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img [^>]*)(srcset=""[^""]*"")([^>]*>)";
string substitution = @"<picture>\n<source \2 type=""image/webp"">\n\1\3\n</picture>\n";
string input = @"<img src=""/media/blog/JPG/3.jpg"" srcset=""/media/blog/3.webp"" alt=""гардеробная""><img src=""/media/blog/JPG/4.jpg"" srcset=""/media/blog/4.webp"" alt=""гардеробная"">
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}