import re
regex = re.compile(r"(<img [^>]*)(srcset=\"[^\"]*\")([^>]*>)", flags=re.MULTILINE)
test_str = ("<img src=\"/media/blog/JPG/3.jpg\" srcset=\"/media/blog/3.webp\" alt=\"гардеробная\"><img src=\"/media/blog/JPG/4.jpg\" srcset=\"/media/blog/4.webp\" alt=\"гардеробная\">\n")
subst = "<picture>\\n<source \\2 type=\"image/webp\">\\n\\1\\3\\n</picture>\\n"
result = regex.sub(subst, test_str)
if result:
print(result)