# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[\w])(?:_([a-z]))([^_"]*+)(?!"\s)|"_([a-z]+)"/"$3"\U$1\E$2/g;t' <<< "{
\"_id\": \"1\",
\"point_altitude\": 530,
\"equipment_id\": \"3325\",
\"header\": {
\"raw_message\": \"\",
\"message_type_id_ext\": \"ping_event\"
}
}"