using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\w])(?:_([a-z]))([^_""]*+)(?!""\s)|""_([a-z]+)""";
string substitution = @"""$3""\U$1\E$2";
string input = @"{
""_id"": ""1"",
""point_altitude"": 530,
""equipment_id"": ""3325"",
""header"": {
""raw_message"": "",
""message_type_id_ext"": ""ping_event""
}
}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}