$re = '/(?<=[\w])(?:_([a-z]))([^_"]*+)(?!"\s)|"_([a-z]+)"/';
$str = '{
"_id": "1",
"point_altitude": 530,
"equipment_id": "3325",
"header": {
"raw_message": "",
"message_type_id_ext": "ping_event"
}
}';
$subst = "\"$3\"\U$1\E$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;