use strict;
my $str = '{
"_id": "1",
"point_altitude": 530,
"equipment_id": "3325",
"header": {
"raw_message": "",
"message_type_id_ext": "ping_event"
}
}';
my $regex = qr/(?<=[\w])(?:_([a-z]))([^_"]*+)(?!"\s)|"_([a-z]+)"/p;
my $subst = '"$3"\\U$1\\E$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";