import Foundation
let pattern = #"(?<=[\w])(?:_([a-z]))([^_"]*+)(?!"\s)|"_([a-z]+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
"_id": "1",
"point_altitude": 530,
"equipment_id": "3325",
"header": {
"raw_message": "",
"message_type_id_ext": "ping_event"
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$3"\U$1\E$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)