const regex = /(?<=[\w])(?:_([a-z]))([^_"]*+)(?!"\s)|"_([a-z]+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[\\w])(?:_([a-z]))([^_"]*+)(?!"\\s)|"_([a-z]+)"', 'g')
const str = `{
"_id": "1",
"point_altitude": 530,
"equipment_id": "3325",
"header": {
"raw_message": "",
"message_type_id_ext": "ping_event"
}
}`;
const subst = `"$3"\U$1\E$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);