# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?s)(?<!\*)\*{2}(?!\*(?!\*(?!\*)))(.*?)(?<!\*(?<!(?<!\*)\*\*))\*{2}(?!\*)/#### $1/gm;t' <<< "
**Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
**
****
[[Nem tudom maygorul]] hungarian is difficult :)
[[Nem tudom maygorul]]"