const regex = /(?s)(?<!\*)\*{2}(?!\*(?!\*(?!\*)))(.*?)(?<!\*(?<!(?<!\*)\*\*))\*{2}(?!\*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)(?<!\\*)\\*{2}(?!\\*(?!\\*(?!\\*)))(.*?)(?<!\\*(?<!(?<!\\*)\\*\\*))\\*{2}(?!\\*)', 'gm')
const str = `
**Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
**
****
[[Nem tudom maygorul]] hungarian is difficult :)
[[Nem tudom maygorul]]`;
const subst = `#### $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);