# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?s)(?<!\*)\*{2}(?!\*(?!\*(?!\*)))(.*?)(?<!\*(?<!(?<!\*)\*\*))\*{2}(?!\*)"
test_str = ("\n"
"**Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről\n"
"**\n"
"****\n\n"
"[[Nem tudom maygorul]] hungarian is difficult :)\n\n"
"[[Nem tudom maygorul]]")
subst = "#### $1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.