#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?s)(?<!\*)\*{2}(?!\*(?!\*(?!\*)))(.*?)(?<!\*(?<!(?<!\*)\*\*))\*{2}(?!\*)"
Local $sString = "" & @CRLF & _
"**Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről" & @CRLF & _
"**" & @CRLF & _
"****" & @CRLF & _
"" & @CRLF & _
"[[Nem tudom maygorul]] hungarian is difficult :)" & @CRLF & _
"" & @CRLF & _
"[[Nem tudom maygorul]]"
Local $sSubst = "#### $1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)