using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?s)(?<!\*)\*{2}(?!\*(?!\*(?!\*)))(.*?)(?<!\*(?<!(?<!\*)\*\*))\*{2}(?!\*)";
string substitution = @"#### $1";
string input = @"
**Az akkád shadu, asszír-babiloni sadu = hegy szavai sátáni összefüggéséről
**
****
[[Nem tudom maygorul]] hungarian is difficult :)
[[Nem tudom maygorul]]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}