using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<h6 class=""event-title"">(.+?)<\/h6>";
string input = @"<h6 class=""event-title"">Brisbane Lions v Hawthorn Football Club and Anthing else we wish here including @#$%^&*(</h6>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}