use strict;
my $str = '<h6 class="event-title">Brisbane Lions v Hawthorn Football Club and Anthing else we wish here including @#$%^&*(</h6>';
my $regex = qr/<h6 class="event-title">(.+?)<\/h6>/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}