re = /<h6 class="event-title">(.+?)<\/h6>/m
str = '<h6 class="event-title">Brisbane Lions v Hawthorn Football Club and Anthing else we wish here including @#$%^&*(</h6>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end