package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<h6 class="event-title">(.+?)<\/h6>`)
var str = `<h6 class="event-title">Brisbane Lions v Hawthorn Football Club and Anthing else we wish here including @#$%^&*(</h6>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}