const regex = /<h6 class="event-title">(.+?)<\/h6>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<h6 class="event-title">(.+?)<\\\/h6>', 'gm')
const str = `<h6 class="event-title">Brisbane Lions v Hawthorn Football Club and Anthing else we wish here including @#\$%^&*(</h6>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}